X96 Max+ Won't boot into EmuElec off SD

Android TV N00b here, and I sure could use some help when y’all have the chance. I purchased a device from GeekBuying that was described as: X96 MAX Plus 4GB/32GB Amlogic S905x3 Android 9.0 8K Video Decode TV Box Youtube Netflix Google Play 2.4G+5.8G WiFi Bluetooth 1000Mbps LAN USB3.0.

I have followed your guide multiple times, but can’t get the device to boot into EmuElec. Tried without reset button (boots normally), tried with reset button (goes to recovery mode), Tried via the app (it goes to a black screen and gets stuck there). I downloaded EmuELEC-Amlogic-ng.aarch64-4.2-Generic.img and Etchered it to a 64 GB micro SD. I tried both the 4 GB generic and 4GB 1 Gigabit dtbs, putting each at root and renaming them to dtb.img. No luck, nothing I tried would make the installation launch. I will attach some technical specs and perhaps they will offer some ideas on what I should try next or help explain what the problem is. Looks like I can only embed one media image, but I have more if you’d like.! x963|375x500

Thanks in advance for any help :slight_smile:

From other users post, I guess, most likely, the bootloader is locked. You box is not allowed to boot from SD card. I suggest:

  1. try if the box allow boot from USB (just plug the SD card to a USB card reader or write EmuELEC iso to a USB stick)
  2. If USB boot is also blocked, reflash the firmware of your TVbox. Find a firmware with unblocked bootloader.

I have a X96 Max+, too. I don’t have any problems like yours, so I have never reflahed the firmware, and I don’t know which firmware has unblocked bootloader. You have to find it.

Thank you very much for the quick response. I slapped that SD in a card reader, put it in the USB 3.0 slot, rebooted with reset (inside audio jack) held down with a toothpick, EmuElec appeared, I left go of the toothpick and it seemed to install flawlessly. Such a simple fix, thank you SO MUCH. This seems like a great step to incorporate into the official installation guide.

I am wondering which do you think it’s the official installation guide? because that is already mentioned on step 4: How to Install · EmuELEC/EmuELEC Wiki · GitHub

That’s the guide I used. I’m not trying to be a bother with word-smithing the thing, but on that main page I only see USB mentioned here under 2. “Use the fastest SD card you can find, it does make a difference! not all SD cards/USB drives.”

Adding something to step 4 like “If the SD card slot doesn’t boot you into EmuElec, try the USB via a USB SD card adapter” might spare you more questions like mine in this thread. Just offering it as a suggestion.

Your wording made it sound like it was the “toothpick” not mentioned, I apologize.

Haha, I was reading and re-reading and control Fing for USB on that page saying to myself, how did I miss that?

No problem at all. I tried to describe my actions in as detailed a manner as possible, hoping that it might prove useful to someone else who’s missing a step.