Sofobod HK1 will boot failure

Looking for insight if anyone can help. I have a HK1 TV box. I have checked the hardware using Aida64. I have a S905x3 4gb Ram. I have properly followed instructions on the EmuElec page. I downloaded the EmuELEC-Amlogic-ng.aarch64-4.2-Generic.img.gz version and flashed it to a clean 256gb Sandisk SD card using Rufus. I have tried both the sm1_s905x3_4gb.dtb and sm1_s905x3_4gb_1gbit.dtb.

I have tried booting EmuElec using the Android Terminal, the Reboot to Libreelec, and the reset button, but every time the HK1 reboots to the android system boot screen. I am wondering if it could be a firmware problem, but have found no information on HK1 firmware, or were to find a firmware version that works with EmuElec. Any help with this would be greatly appreciated.

Do you have another smaller SD card to test?

I tried an older 128gb card. This time I tried the different dtb files, and it didn’t boot to the android boot screen, instead it loaded for a second and the display cut out. it didn’t go to a black screen, the TV could no longer detect a source. Do I need to go to an even smaller sd? Thanks for the help so far feels like I’m making progress.


I just tried a 32gb sd card and this one booted to the android boot screen, instead of trying to run EmuElec.

This seems like the dtb is wrong, try all the “sm1_” dtbs and make sure you are renaming the dtb to dtb.img with no hidden extension.

Maybe you can provide more info of your device. Install HWinfo app in Android. Take some screenshots and put them in the forum. It may help other people identify spec of your device.

In CoreELEC forum, I read one post about S905X3 device no boot to CoreELEC on microSD card. The author finally resolved the problem by flashing certain official firmware. It seems some TV box are shipped with firmware not allowing boot from microSD or USB.

BTW, you can also try put your microSD card in USB card reader and boot from USB.

I am in the same boat as this person, with the Sofobod HK1. The device came rooted, so is it correct to assume that if it will not boot off the SD card then it must be an issue with either the SD card I am using or the image?

Also, would the boot issue be fixed by flashing the firmware with another rom? For instance, I know on XDA developers forum there are some image I could try, like SLIMBOX or Aiden’s rom.

So for me, I did manage to get this working by using a patriot 64gb usb flash drive, and putting it in the USB port on the side of the device, as opposed to the corner. Curious if the ability to boot from SD card, or USB ports is set in the firmware, or if its viewable in hwinfo.

It is set by the firmware installed, and unfortunately there is no way of telling that I know of. That is why some people have needed to re-flash older versions of the FW for their boxes, there is nothing we can do to change that.