Unable to boot 4.4 or 4.5 in T95M (S905X-2GB)

Hello, I´m unable to boot those versions and don´t know why.
I have been using CoreELEC+EmuELEC addon with this box for some time, but I have found an interesting project called HybridELEC, with CoreELEC+EmuELEC dualboot I want to try
That project use EmuELEC 4.5 and this is where my problem begins.

I have Downloaded the official EmuELEC 4.4 and 4.5 and both of them reports the same error
It boots up, resize the partitions, reboots, and then it installs and reboots just like the 4.3 version, but when it restart and appear the message “…setting config dir…” ir report an error

 [FAILED] Failed to start Generate system-wide /etc/environment file.

Any idea how to solve it?? I´m using the dtb named gxl_p212_2gb as always
I assume it must work in this box having a S905X and 2GB ram.
4.3 works with no audio.
Thanks in advance

For 4.3, are you using Amlogic or Amlogic-ng image?

4.3 is the last version that provides non-ng image and -ng and non-ng use totally different kernels. The 4.9 kernel in -ng images, different from 3.14 kernel in non-ng images, can only work with boxes with a >7.1 Android firmware (Technically we only need the bootloader from >7.1 Android firmware, but you woule have >7.1 Android anyway)

I´m using the 4.3 amlogic-ng image, and the box came with android 6.0.1

So if I´m right first I have to install an android >7.1 to be abble to boot into newer kernels?

I´m thinking… I´m using CoreELEC-ng 19 and even try CoreELEC 20 in this box and both have 4.9 kernel, don´t know if that could help…

Now that’s more wierd… Hold on about the Android upgrade, I think there’s something wrong in EmuELEC’s bootup process that needs fixing

LATE!!! jajajajajajjajajajaja
I couldn´t wait so I have taken another exact box I had with ATVXperience and android 9.0 and tried your HybridELEC fork again.
EmuELEC working perfect and reboot to CoreELEC working perfect so you were right about the bootloader in >7.1 Android. Thank you very very much

Anyways I think it should work in the other box with Android 6.0.1 as CoreELEC does

I have both boxes at home, one in the livingroom and the other in the bedroom atached to a projector, so if you need me to try different things I´ll be glad to help you and the comunity.

not sure why, in my tests with s905x 1gb ram android 6 i have been able to boot 4.4/4.5 ng without problem.

anyway i found sound and system performance problems, some could be due to low ram in my case, but pretty sure it’s something related to new kernel

Until a new non-NG build (amlogic_old 4.6) is released I recommend using 4.3 non-NG which has very good overall performance, only some sound problem in emulationstation but not in games.

I´ve been doing more testings
If I take the microSD I have done in the android 9 box and put it in the android 6 box both systems works perfect