Ugoos x2 cube usb wont work on emuelec

hi, i installed emuelec4.2 on the sdcard it boots setup and restart but none of the usb ports is working.
When i went back and boot back to android my ports are working ok

is there a fix to this?

Try to enter these commands using SSH and look to see if the USBs work.

echo 432 > /sys/class/gpio/export
echo out > /sys/class/gpio/gpio432/direction
echo 1 >  /sys/class/gpio/gpio432/value
echo 432 > /sys/class/gpio/unexport

Edit: If it works, add the lines at (or

im a noob so how do i do this when i cant even add my keyboard to the unit?

he said ssh from pc to the unit
use the pc keyboard

i say again im a noob i have no idea how to ssh

This is probably a decent time to try to learn how to:

any idea how i can activate the ssh server on thatbox?

no other way to add this in the sdcard itself?

If your USB ports aren’t working off the hop and thus have not controller options you have a little more messing about to do. Does your box have android installed and does it have an included IR remote?

As far as I recall, the option to use an IR remote is available in EmuELEC, but you have to copy the android remote.conf to the root directory of the media you installed EmuElec to, on the first boot attempt it should discover it and move it where it needs to go.

The remote.conf is usually found in android in /etc/ or /system/etc/ copy that to a separate USB stick, and have it ready. Reinstall emuelec to the media you tried to use first, copy the remote.conf to the root directory, try to boot emuelec.

If that all goes well, you should be able to navigate with the ir remote to enable SSH and try the above instructions.

More detailed info here:

so no one used this box and emuelec b4?

i noticed when emuelect boots the led on my usb devices are off but when android boot up it work fine and the leds ligth up

But have you tried this solution? I tell you, because other users with Ugoos solved it that way.

i cant .even activate the ssh i cant input to the box… my ir remote is dead.

can we do this on the command line when i run emuelec on the box?
Apprenrtly when i push the reset button untill the update icon appears during bootup my usb ports are okay but when i shutdown and reboot asper normal the usb ports wont work

There is a problem with usb on X2 Cube running Emuelec (and Coreelec).
The solution is in post #2 by SamWilson.
To access config files connect your box to PC by ethernet, open network shared folder EMUELEC, navigate to Configfiles. Open and add 4 lines with commands in section “before”.
SSH on Emuelec is activated so you can perform reboot (user:root pass:emuelec command:reboot, on Windows you can use Putty).
On Coreelec can’t find any option other than reset or unplug the power (no SSH by default).

i tried the ‘press reset button until update appears’
That is when my USB ports worked normally. Normal power down and startup my my USB ports will not work.
Anyway i tried terminal and i can’t seem to be able to locate ‘’.
Where is it located . Also im new to linux. How do i edit files in Linux terminal?

Don’t use SSH and command line interface (as you new for it).
Use SMB/Windows shared folder instead.
In Windows Explorer open Network > EMUELEC > Configfiles.

1 Like