Gamepad detected only in pairing mode

Hi, I recently bought Belink GT King and installed emuelec 4.6 on emmc with android dual boot.
I have problem with one of my gamepads. I have wired OEM xbox 360 gamepad and it’s working great and I have another OEM wireless bluetooth xbox gamepad that connects over bluetooth and works on android, pc and android tv but with emuelec it doesn’t. It is recognised by emuelec and in retroarch when in press and hold pairing button to enter pairing mode but I can’t map any button or anything else.
Please help so that my children can play those great retro games in two player mode.

Please if can someone help me or point me in the right direction or simply tell me if it is not possible. Thx

Try to SSH into your device, username root password emuelec, then copy/paste this command:

 cat /proc/bus/input/devices

then post the output in a gist file here and provide the link in this thread:

1 Like

Hi, here it is:
emuelec xbox gamepad (
Hope I did it right.

I didn’t mention it but I tried like it’s in the wiki - manual pairing or to enter gamepade pairing mode before i boot emuelec, but nothing helps.

Have you tried doing a direct connect with a cable for the wireless controller. I noticed it’s also registering as a keyboard which for some reason ES does not recognize.

1 Like

So I bought cable today and when connected that way emuelec recognized it. I mapped buttons, tried some games, everything works. But when i discconect cable nothing works again same thing. What can I do to make this gamepad work in wireless mode?

I’m not sure there is anything you can do at the moment. Our bluetooth software as it stands does not recognize a few devices hopefully newer versions when they come out will support more controllers.
in SSH you can check some debug output with:

dmesg | grep -i blue

and it may help us debug the issue, but I am pretty sure its our bluetooth software that is the issue.

1 Like

Thx. Should I run this command when gamepad in pairing mode or when connected with cable?

After you have tried to connect via Pairing mode.

Ok, so for now I’m using cable. Here is output of that last code:

gist:f814c435cc9f3a9d4a4af85123fa3428 (

Have you read this link?

the error in your output:

Bluetooth: SMP security requested but not available

Seems to suggest that the bluetooth agent is not running properly from what I’ve read online.

Yes I read it before posting any question, and all topics here that are about wireless joystick/gamepad. I wrote in third post that I tried everything in wiki about bluetooth and it doesn’t help.