Amlogic S905X3 [Emuelec 4.2] - Bluetooth Gamepad Issue

Bluetooth Gamepad not working when launching game.

-The Bluetooth Gamepad can be detected and paired.
-The Bluetooth Gamepad is working correctly in Emuelec menu.
-Tried starting retroarch and setup the controls manually.
-The Bluetooth Gamepad is now also working on retroarch Menu.

But every time I started a game, the controls won’t work anymore.
I know the Gamepad is still connected and all controls are mapped correctly since I can access the retroarch menu, they just wont work in the game only.

Any ideas how I can make this work?

I don’t know how to solve your problem, but I would suggest you provide the specs of gamepad and box. If you can, pasting a log will be better. These info may be required to identify the cause of your problem.

I have a genuine DS3 controller and a S905X3 box. I don’t have a problem like yours.

1 Like

Thank you! I’m new to this so I don’t have any idea where to get the logs.

The device I’m using is the same as the ETA Prime video. T95 Max +
My controller is a cheap Popcorn X3/T3 Wireless Bluetooth Gamepad.

The controller is working properly in the PC version of retroarch. I just cant seem to make it work in the retroarch emuelec only.

Its weird that the controller is paired and is working correctly in every area in emuelec, including the retroarch menu but just not in the game…

Anyways thanks again for the response! any help is appreciated.

*the dpad does work if I disconnect and connect again while in game. but only the dpad and nothing else.

Hello, in theory when you map your gamepad in EmuELEC it uses the same configuration in retroarch and it seems that for some reason it is not working well. Have you tried to remap your gamepad in retroarch? (Hotkey + y) go to: settings / controls / port 1


Thank you for the response!

This is now resolved. It seems that it wont work if I run and set it up independently in retroarch.
It needs to be set in game when you run it straight from emuelec menu. I used a keyboard to setup everything first and used the connected controller to remap.


1 Like

Hi what exact box are you running? I’m having the same issue except my controller will not connect at all on 4.3 even with the tethered cable.