Odroid n2+ not boot emuelec

Hello everyone!!! help!!! I cant boot emuelec by micro sd in odroid n2+!!! Anyone send odroid n2+ tutorial or support for that? thanks!

i think some more infos would be nice…

  • Did you d/l the corret version of EmuElec for your device?
  • Did you wrote the image to the SD or just copied only the image file?
  • Does your Odroid N2+ boot from your SD when turning on?
  • What happens exactly?

The more information you give, the sooner someone can probaly help you.

Dear friend, the main emuelec problem now is stuks when take place instalation…Frozen…

Have you tried to use another / new SD-Card?
Could it be that your SD card is faulty - and that’s where the installation problems come from?

you are not cooperating.
what version of emuelec are you using?
where did you get it?
installation on MicroSd or emmc?
Does the installation even start?
If you do not provide the minimum necessary information, the topic will be closed.

Sorry for delay… Good and bad news update… I get instaled emuelec but… version 3.7!!! I tried all version only v 3.7 works. Please help me to running v 4.3.

Hi guys,
I’m a complete noob in this, but could someone clarify how can I install EmuElec on Odroid N2+? Should I instal that on SD and use USB 3.0 SD adapter, or can I install it directly on the emmc? Do I need eMMC with Android to boot the emuelec or usb adapter with sd and emuelec is enough?