Emulelec 4.2 - BlueMSX Bios missing hardwareconfig.xml in several Machine folders [SOLVED]

Emulelec 4.2 - BlueMSX Bios missing hardwareconfig.xml in several Machine folders.

See: Emulator - BlueMsx on MSX roms - ElecEmu Error. · Issue #654 · EmuELEC/EmuELEC · GitHub

I’ve looked all over the net for these hardwareconfig.xml files and could not find them.

Has the BIOS, Database and Machine folders, but no hardwareconfig.xml files which the BlueMSX is complaining needs to run.

I’ve also got EmuElec v3.8 and it runs fine, and I copied the BIOS folder straight over so 4.2 should also work, but it doesn’t.

Help pleaaseeee T-T it’s driving me insane.

I think I need an older version of aarch64 bluemsx_libretro.so before they decided to add that hardwareconfig.xml crap. Can we get an older revision compiled as I’m not sure how to do it myself.

I copied the working bluemsx libretro “.so” file in v3.8, and uploaded it to the cores of v4.2 and added the 32b to the filename so the 32-bit version runs. However I still got the same error. I checked on my v3.8 of EmuElec and search for “hardwareconfig.xml” files everywhere and none were found.
I don’t know allot but I’m pretty sure it’s not me and there is a bug in either the launcher or retroarch itself. How can I get retroarch to verbose output when run with the launcher? As it seems to be terminating without enough info as to why it’s terminated.

Finally worked it out.
It turned out that it was missing the correct system directory configuration in RetroArch by default:
so it should be re-configured from:
system_directory = “~/.config/retroarch/system”
system_directory = “~/roms/bios”

If you could update EmuElec to reflect this that might save someone headache lol if it hasn’t been already. I’m surprised that allot of the emulators otherwise worked.

Might also add in Addition to the Machines, and Database folder files need to be in BIOS, so does DISK.ROM.

Thanks and best of luck. :smiley:


I’m glad you solved it, although I haven’t reproduced this, it works fine for me just copying databases and machines folders into roms / bios folder from many versions back to actually 4.2 :confused:

Glad you figured it out, but I have no idea how you ended up with that path, by default its set to ~/roms/bios You must have changed it manually somehow.

I think I copied across a retroarch.cfg from the retropie, not an earlier version of emuelec, and that is why some of the paths were broken. I’m so silly haha, anyway glad its working now. XD

1 Like