DTB for Rockchip RK3566 android TV box

Hello!

I recently acquired this device: https://www.amazon.com/dp/B09LKTKWKV?psc=1&ref=ppx_yo2ov_dt_b_product_details except it says ‘Greva’ in place of ‘Rupa’ on it. It was cheap ($40) at the time I bought it and I had thought it would be easy to load Emuelec on it since I saw there was an image for this chipset on the latest beta I’ve been using for a couple similar S905X4 boxes I have.

I can get it to go into recovery but it doesn’t boot from the 64GB MicroSD card I flashed with this image using Rufus: EmuELEC-RK356x.aarch64-4.6-TEST-07082022-rk356x.img.gz

I had some initial trouble with my first S905X4 unit as it claimed to have 4GB RAM and a 1Gb ethernet NIC but I found a thread here where someone else had a box with only 2GB RAM + 100Mb ethernet and once I found and used a DTB file with those corrected to the true values I got it to work. During the time I was having trouble with it, it was behaving similarly to the RK3566 box I have now that won’t boot.

I read that sometimes they can only boot to a USB drive so I tried putting the MicroSD card with the image on it into a USB adapter and it still didn’t boot. I don’t know if that is a valid test or not, I’ll have to find a USB flash drive to write the image to… but I’m confident that 99.999999% of the time I’m not the first one to experience any given tech issue so I thought I’d ask here if anyone has solved this problem already or if I’m missing something obvious or simply doing something dumb without being aware of it.

Any/all help would be appreciated! Thx! -T

I don’t think there is a DTB for that device, the RK356x EmuELEC build is only for 3 specific devices, Odroid M1 and Firefly M2/P2. That device is a generic box.

Thanks for your reply. How does one go about building a DTB file? I can get it to show me DMESG output in the Android Recovery. I saw in a thread about the S905X4 someone was talking about extracting it from Android. Is that possible? I mean if there’s an image for the RK3566 it seems like that would be the key to making it work. Having the specific device tree. Or is it a matter of there may not be device drivers for devices in the tree?

If I’m oversimplifying, my bad. It seems like having the image for the chipset would be like 98% there… No matter what, though, thanks for your time. Perhaps I got overconfident with some success on misc. generic S905X4 devices after beating my head against the wall and not being able to get those devices working for weeks. I know in that case it most definitely was a matter of having a correct DTB file. Incorrect DTB = dead in the water. Correct DTB = Alllllright!!

Now I just have to figure out how to derive, extract, generate or fake one. Ha! Thanks again!! -T