Controller problems with 4 6 openbor amlogic s905x3

Ok please bare with me im fairly new to emuelec. Since installing 4.6 openbor wont map “up” and “right” on the joystick. Using dragorise encoders.

All was working fine with 4.3 so something has changed. Any help on fixing this would be great.

Thank you

One more thing to note:
Replacing es_input.cfg should map DS3 controller correctly under EmulationStation (the default UI of EmuELEC), as I have tried. As to the emulators launched from EmulationStation, it’s not guaranteed the controller got correct mapping from EmulationStation. I haven’t got the time to really play a game using EmuELEC.

Thanks iv already tried this as seen your post yeaterday :grinning: for me it made things worse though :cry:

Sorry, my previous reply mistakenly posted in your thread. That’s not what I meant to. My target should be post in my own thread about DS3 controller not mapping correctly (Default controller mapping is weird in v4.6 - #7 by kylecp1979).

My suggestion to replace es_input.cfg only applies to genuine PS3 SIXAXIS controller. That’s what I have tried and confirmed working. As to other controllers, nothing I can say.

Your controller problem happens in playing OpenBOR, not in EmulationStation UI. Therefore, replacing “es_input.cfg” is not a solution for you.
My previous mistaken post also mentioned it.

I have only played OpenBOR in Windows 10. Based on my experience, the controller input can be re-mapped in OpenBOR UI. You should try it. The input mapping of EmulationStation has nothing to do with OpenBOR.

I have tried to remap. All buttons will remap, its only up and right on the jotstick that wont remap. Its something that has changed with openbor as it worked in 4.3. All other emulators map fine

Anyone got any ideas please? Anyone else got dragonrise zero delay encoders to test? Thanks

@EmuELEC any ideas ? Thanks

It’s probably because SDL recognise left and right as the same analog axes with dragonrise, check in sdljoytest. You might have to specify them as buttons instead by manually editing the inputs for openBOR.

Thanks for your reply. Where is tbe sdjoytest file located please?

its a command you enter when you access your device via SSH.

Thank you. Also where would i edit them for openbor manualy? The master file makes no sense to me lol

Good Question I see the master cfg file is in binary, someone with more openBOR knowledge might be able to help you, as I am not familiar with the emulator, sorry. :frowning:

1 Like

Thank you. Hopefully someone can help. Been pulling my hair out for over a month lol

I just tried to play Golden Axe Returns on OpenBOR. My genuine PS3 controller is working default on D-PAD. I can re-map it to left Analog joystick in game. Not a problem found.

I guess you have an unsupported controller. The matching device driver is just not available. Since you never provide any info about your controller, I can only suggest go grab a supported controller.

BTW, I also tried to find where OpenBOR stores its config in EmuELEC, but I can’t find it. I can’t find it in Windows 10, too. I am curious about how OpenBOR stores its configuration.

Every other emulator works fine though. Also it worked fine upto emuelec 4.3. I have said its dragonrise. Dragonrise is the most popular arcade zero delay boards going and are deffo supported

Where do you get the supported controller list from?

I dont have a clue sorry