Default controller mapping is weird in v4.6

Just tried v4.6. My controller is genuine PS3 dualshock SIXAXIS controller. Bluetooth connection is working.
It’s weird that key mapping is wrong. I can only use left analog joystick to control menu up/down/left/right. D pad UP is choose, DOWN is cancel(or back, or GO TO MANUFACTURER), LEFT is QUICK SEARCH.
R1 and L2 move menu-item to right, L2 moves menu-item to left, L1 no respnse (or unknown action).
I don’t have the problem back in v4.5.

The log :

I have checked gampad config “Sony PLAYSTATION(R)3 Controller.cfg”, and found it has not been changed. What could be the cause of the irregular key mapping on my device?

BTW, in “EmuELEC/tree/dev/packages/sx05re/emuelec-emulationstation/config/es_input.cfg”, I see that PS3 controller has no deviceGUID as other controllers. Will it help if deviceGUID got appended?

Try remapping the controller buttons, in EmulationStation, under bluetooth and controller settings.

Thanks. I know that controller mapping can be manually set. It’s not a problem.
It’s just weird that the default mapping for genuine PS3 controller got changed. Maybe the developer will be interested in the issue, so I post my log.

I’ve noticed ever since v4.4 came out controls have been worse. I have stuck with 4.3 for the longest time but after they ported tmntsr to 4.6 I have been manually changing controls around to work as they did with v4.3. I know a lot of the arcade encoders don’t work right in v4.6 psp only works with left and down. Arcade controls are all over the place. Using players 1 and 2 joysticks for dual stick arcade games no longer is configured you have to manually do that also. And I can’t get the joysticks to work in tmntsr any help would be appreciated. I’m using the dragonrise usb encoder.

I replaced /storage/.config/emulationstation/es_input.cfg by copying the same name file from Batocera. My PS3 controller is now mapped correctly without manually remapping.

I’m going to have to try that thank you for the info!

1 Like

Some of my posts on this topic went to other two related threads. My mistake, but that’s not what I meant to.

To summarize:

  1. replacing “es_input.cfg” only affects EmulationStation (the default UI of EmuELEC). Each emulator or port game (such as OpenBOR, RetroArch, MAME, FBNeo…) has its own input config.
  2. I have only tried with a geniune PS3 SIXAXIS controller. It works. As to other controllers, if its deviceGUID is included in “es_iinput.cfg”, it might also work. I can’t say for sure.

There is a way to check if your cotroller is supported in “es_input.cfg”.

  1. Get VID&PID of your controller. There are several ways. One is using Windows control panel.
  2. Check if VID& PID is included in es_input.cfg. Note, in es_input.cfg, the order of VID& PID is reversed. See the attached image.