Joystick for PS3 doesn't work propertly from 4.4 to 4.6

I have a fightstick from Mayflash that is originally for PS3. When I use Emuelec 4.3 it’s works fine. When I update to Emuelec 4.4, 4.5 or 4.6 doesn’t work propertly. Some buttons don’t work and others do so I can not mapping the controller.

The wierd thing is that once that I connected the controller, rather than show Sony PLAYSTATION(R)3 Controller Connected, it showed HID… something (I don’t remember the numbers) and the buttons that haven’t been working, now work, however it only happened once.

So I guess the problem is related how the system detect the kind of controller connected. But as I said previously, no problems with Emuelec 4.3.

Any thoughts on that?

Thank you in advance.

Try and use a compatible PS3 gamepad and press start, Wireless and Controller Settings, Map Controller Input. Then select your fightstick and assign buttons. Ones that arent used hold a button down to skip it being assigned.

I have already tried this. The problem is that some buttons doesn’t work so I cannot assign them.
The joystick is and USB version not BT.

I’ve done several tests. I’ve copied the controller configuration from the version that it works (EMUELEC 4.3) to the version that doesn’t (EMUELEC 4.6). I’ve copied the Sony PLAYSTATION(R)3 Controller.cfg from Joypads and es_input.cfg from Emulationstation Config. I also copy the es_input.cfg from ConfigFiles-emulationstation.

After doing that, as long as I connect the joystick when the sytem boot up, the configuration is assigned correctly to the joystick and seems to work fine.

However, once I disconnect the joystick and connect again, the configuration is missed and some buttons don’t work.

Once I connect the joystick again and restart the system, works again.

The same occurs from retroarch menu.

It’s seems like there is some problem when detect the joystick when emuelec is running.

Any idea what may happen?

We are trying to work on a fix so you wont have to manually adjust things.


Just tried a quick solution. It works.
I copied es_input.cfg found from Batocera github (the path is : batocera.linux/package/batocera/emulationstation/batocera-emulationstation/controllers/) and replaced the one in EmuELEC (the path is : /storage/.config/emulationstation).
Then reboot.
My genuine PS3 controller can be correctly mapped.