S905 Le Potato Issues With Sound

Hey y’all,

Hopefully posting in the right category… Anyways installed EmuElec on my Le Potato a couple days ago. Noticed no audio in the intro video so changed the audio settings in EmuElec to 0,1 and that audio now works for the intro. However when I try and play one of the pre installed roms like 2048 I get no audio nor audio in the menu navigations.
I tried going into retroarch to play with the drivers as other people have but there are no save options so it looks like it doesn’t save when I exit out. Any help would be appreciated. I am running a converted A1up with a hdmi adapter to get sound out of it.

In Retroarch try adding the audio device “hw:0,1”.

Also make sure you have save on exit enabled.

Will do! Where can I find the save on exit option? I was looking for it before but just looked again and still can’t find it! Appreciate it!

Ok so update… Using V4.6. I still get audio during the splash/intro video. I decided to try uploading a .mp3 to the BGM folder and am getting audio through that. Still no audio for menu navigation or games however. I also can’t get retroarch to save in menus.

In EmulationStation try in EmuELEC Settings >> Audio Device >> 0,1. reboot.
For retroarch SSH in and copy/paste this line:

sed -i "s|audio_device = .*|audio_device = \"hw:0,1\"|g" ~/.config/retroarch/retroarch.cfg

Awesome Ill test this when I get home. Anyway I can get to the config files for retroarch not through ssh? Just realized Le Potato doesn’t have a Wifi module so will have to order an ethernet cable. Thanks again!

You need a linux variant to read and edit the storage drive as its in ex4. the file to edit is /storage/.config/retroarch/retroarch.cfg, and value to change is:
audio_device = “hw:0,1”

So I’m basing my audio on the fact that I am not hearing menu navigation sounds. I guess I should have asked: are there any navigation sounds? I can here my mp3 files and such from my folder but when I turn that off no sounds at all. Haven’t tried any games yet except 2048 but I’m not sure if hat has sound. Having trouble loading games in.

For sound to run instead through the jack try this command in SSH:

 wget https://gist.githubusercontent.com/Langerz82/3c35dce912fde05a6363c40765e3d358/raw/3e393fcc673a70e6088063ed86ad3b6e820bff35/asound.conf-amlogic-ng -O /storage/asound.conf-amlogic

If you are using an amlogic-ng image use this:

 wget https://gist.githubusercontent.com/Langerz82/3c35dce912fde05a6363c40765e3d358/raw/3e393fcc673a70e6088063ed86ad3b6e820bff35/asound.conf-amlogic-ng -O /storage/asound.conf-amlogic-ng
1 Like

So my set up right now is I’m running through an hdmi converter to my arcade1up display and was hoping to get audio out of there. When you say through the jack do you mean the hdmi audio out or the pi audio out?

If it’s through the hdmi out, you should not need to change the value to hw:0,1. Changing it may stop the audio coming out of the devices hdmi out, and instead go out through the devices audio jack.

When its on auto the hdmi out doesn’t have any sound output but with its on any of the other ones I can hear the intro video. Is there main menu music/navigation sounds I should be hearing? I was able to ssh into the le potato and run those scripts you sent. I restarted it and didn’t notice any changes, good or bad.

If you want sound through the hdmi you probably have to change hw:0,1 back to hw:0,0 with this command and reboot.

sed -i 's|\"hw:0,1\"|\"hw:0,0\"|g' /storage/.config/asound.conf-amlogic-ng

Ok. I just reflashed the chip with 4.6 again to reset any changes. I switched to hw:0,0 first and ran the first line you sent me ( ```
…*|audio_device = "hw:0,1"|g" ~/.config/retroarch/retroarch.cfg)
but with hw:0,0. I didn’t instal the wget link. Do I still need that?

Just got the games on and the sound works on the arcade games. I’m still not hearing any navigation sounds going through the menus

SSH in and run this and get the output of the command and paste it here:

cat /storage/.config/asound.conf

EMUELEC:****~ # cat /storage/.config/asound.conf

not needed

#pcm.!default {

#type plug

#slave {

#pcm “hw:0,0”



EMUELEC:****~ #

Here is the output ^

I downloaded some new themes and the navigation sound works with some of them. I’m guessing the original carbon theme doesn’t have them.

Ah lol, no worries it probably isnt a sound config issue then. Next version of emuelec will fix sound config up a bit so you can just change it in ES >> Emuelec Settings >> Audio Device and selecting each one will adjust the sound config, but not for Amlogic devices because by default the file is all commented out like your output above.

Ah too bad for amlogic devices. Hope development goes smoothly for sound for the next version. I know it threw me for a loop why no sound was coming out for navigation sounds.

The Fix:
If anyone can’t hear navigation menu sounds try downloading different themes. The wheel ones worked with navigation sounds for me.