No sound in gameplay

In Emulationstation menus the sound works well but when I start any game in any platform the sound is off.
I tried all sound drivers in retroarch settings without success.

I have s905d with the 4.3 (last) emuelec

Can be any problem with HDMI only starting libreto?


Hi, which EmuELEC image are you using/downloaded?

Sorry. I did not explain well what I did.

My goal is to make a bootable sd with support for the old and the new gen Amlogic’s devices. I saw that there is enough space in the FAT partition to copy the “old” gen boot files, manteining the new gen files

First, I made the SD using the 4.3 ng image:
I set up and copy some roms to test it. All worked well with this image.

Then I downloaded the the “old” gen image
and burned to another SD. I switched the FAT partition’s files of this image with the files in the FAT partitions of the new gen image. I chosed the rigth dtb and then “old” device booted well with the “new” SD. All settings worked well too.
Well, not all, as I said at the op, the music in the gameplay is off in all platforms.

Maybe the rigth question of the post would be if it is posible to share the same SD for the new and the old gen devices.

Thank you again.

No, u-boot is different, kernel is different

Thank you and sorry for the bad explanation

Then what would be the best way to copy all the settings from one sd to another to avoid make all settings again. Maybe a backup?