Issues with PSX, Saturn & Dreamcast in Emuelec on GT King box

Hi all, I posted here about a month ago with some issues - thanks to those who tried to assist - and i’ve worked through most of those…but encountered a couple other I just cant seem to figure out and am hoping someone can assist. I’m using the most recent version of emuelec with all default settings:

1 - PlayStation 1/PSX games. I can’t get any of these to load at all. I’ve been told I need to convert the files to .PBP files; firstly is that correct? Secondly, I downloaded PSX2PSP to do this, but I get an error every time I try to convert a file, (a BIN or CUE file) something about being unable to open a base.PBP file. Any thoughts there?

2 - Saturn: I dont know if this is game specific or not but I’ve only tried one game,. Primal Rage. The Saturn startup screen boots up, but then when the game itself would load, it goes to black and freezes…I can go into the menu but if I tell it to “Quit Retroarch” or do anything else, it freezes and I have to turn off the power on the system.

3 - Dreamcast…some games play fine, but a couple others, specifically WWF Attitude and ECW Anarchy Rules (both awful games but I have a soft spot for them), the games play their intro vidoes but then crash and error out when I press start.

Thanks in advance to anyone who can assist!

i am an GT-king user too, everything is ok but resident evil 2 under N64 and NGC EMU, maybe you need switch another core or game file, or sd card?