GT KING issues (input lag, config not saving, etc)

Hello…I am having major issues and after spending many days, hours, and a lot of money I am beyond frustrated. I have asked multiple places and can’t get any help. I’m desperate.

I have the beelink gt king box, a SanDisk 256gb SD card and the latest version of emuelec. I am having a couple of major issues that I cannot find a way to solve.

1 - horrible input lag. Easiest way to explain this is if I press jump in Super Mario World, he jumps a half second (or more) later. I tested multiple snes, psx and n64 games and it applies to all of them. I have tried this with 4 different controllers, and just for the hell of it, 2 different TVs. Same story all around.

2 - button layouts not saving in MAME. For instance I play Mortal Kombat 2 and fix the button layout. I exit the game, when I go back in, my changes are all gone. I know from years of using mame on pcs that this shouldn’t be.

I’d be incredibly grateful to anyone who will assist.

If you notice the input lag with 2 different TVs and several controllers, I am afraid I have no clear suggestion other than do not use any kind of wireless gamepad. You can try run ahead, but this will impact performance.

Button layout in which MAME? advmame? if so, you need to disable the advmame automatic gamepad config in EmuELEC settings.

I thought it might be a wireless controller issue as well so I tried 2 wired controllers and they produce the exact same lag.

And I don’t know what emulator in mame I was using, just whatever the default setting is. I’ll try and look at that.

Input lag issues are hard to figure out, specially since people will feel the lag affects them differently, I for example do not notice any sort of lag (especially not a half second lag) , but I have a TV that has “game mode” so that might help. I am not saying there is no input lag, because emulation in general has input lag compared to a CRT on original hardware.

If you are sensitive to input lag I am not sure there is a clear solution.

EDIT: Maybe try some of the other distros like Batocera, Lakka, etc to see if the input lag is present there.

can you tell which version of EmuELEC you downloaded/installed on your beelink?
is it possible that your televisions have hdr or some kind of color dynamic range option activated?

1 Like

I know for sure it’s version 4.3. I think this is the link used?


I’ve already put the TV in game mode…hooked my switch up to it to verify the lag wasn’t just my imagination…and it’s not even close…Mario World is literally unplayable (just giving an example there), switch version he jumps as soon as you press the button. Emuelec version…press the button, let go, move your thumb away from the controller…jump. so I promise, it’s not just being overly sensitive. SF2…press up…wait…jump. It ruins the game entirely. But I can play the exact same rom on my 13 year old laptop with no lag.

The first TV I tried it on is like 12 years old (or more), I don’t think they even had HDR back then.

It’s hard to know what’s going on, we tried all the versions and we haven’t got that problem in any case.

this happens in all your games? in all emulators
are you using any kind of shader in games?

In the 7 SNES games, 5 n64 and 2 PSX games I tried it happened. Didn’t notice it in NES or MAME.

Is it possible the box itself is somehow defective? Or something needs to be changed on the Android side of things? I doubt it but it doesn’t hurt to ask.

I haven’t changed emulators. I don’t even know how. I watched about 50+ videos on “Super Console x” then found one explaining how to make one myself so I bought the components and followed those instructions. It’s crazy because none of the MANY reviews I’ve ever seen mention this issue or having to change emus/settings or anything. It literally feels like I am the only one in the world with these issues.

Shaders? Not to my knowledge. I haven’t changed ANY settings with the exception of running ahead in the latency settings - but I have to run 5+ frames ahead to even mildly affect the issue which also makes it pretty unplayable.

as I suggested, can you please try another distro (Batocera, or Lakka, or I think even Recalbox has a S922x variant) and see if the issue is also present in those? this will help us narrow down the possible causes.

Yeah. I’ll have to figure it out (I’m not tech savvy at all. In the least) but I’ll try it. Hell if anyone thinks it will help I’ll make a video of how it’s running now. I’ll let you know after I’ve tried another program

Is Batocera even compatible with this device? I don’t see one for a s922x build

According to this, it does batocera.linux/batocera-Changelog at master · batocera-linux/batocera.linux · GitHub

batocera.linux 33
        * add: Support for Beelink GT-KING ""
        * add: Support for Beelink GT-KING-PRO ""

EDIT: Seems only available on beta: Index of /upgrades

Ok. I’ll look into that. One more question for now… I disabled the advmame automatic config but now when I launch a game in MAME it doesn’t read the input at all…IE I can’t press a button to go into controller configuration. Is there a way to do this outside of the game?

Try this

1.- Enable gamepad auto config
2.- Set your controls how you want them, save and quit advmame
3.- Disable auto gamepad
4.- Advmame should now have the configurations you set.