I could not use GPIO joystick from ver4.1

The GPIO joystick that was available in version 4.0 cannot be used in later versions. Is there any other way to apply it?
I modified boot.ini to look like this:

load mmc ${mmc_dev}:1 ${dtb_mem_addr} device_trees/sm1_s905x3_odroid_c4_joystick.dtb

the latest is not 4.1, Use 4.3

I tried 4.3(odroid C4). But GPIO joystick does not work. I modified boot.ini as above.

This is not even related, GPIO is way different than Bluetooth. please open your own thread.

1 Like

The one I use is with GPIO on N2+. No separate pcb is used. It was available in version 4.0, but it is not available in later versions. I hope the developer checks it.

Please check whether the GPIO joystick works in version 4.3.(esp. C4)

Since I have no idea what your setup is I cannot really help you, all I know is that this was tested only on the N2 ( on my side) never tested the C4, but are you sure its connected correctly? also, not sure why you changed boot.ini it does not need to be changed, you just need to follow the installation instructions on the wiki.

What worked well in version 4.0 does not work after a fresh installation with a later version. No hardware modifications, only software modifications. Even in version 4.0, I need to modify boot.ini to use the GPIO joystick. Let’s test it once without modifying boot.ini.

you still need to use the proper DTB

[quote=“liva123, post:1, topic:694”]
[/quote] Is " device_trees/sm1_s905x3_odroid_c4_joystick.dtb" is dtb file for GPIO joystick?

I changed device_trees/sm1_s905x3_odroid_c4_joystick.dtb to dtb.img, I tried again, but GPIO joystick doesn’t work.

are you sure that you are using v4.3? because this was a bug fixed on 4.3

Yes, of course, I use v4.3.