Changing the Intro Screen and Load screen?

Is there any way to change the brand name on the load screen and the initial video intro - maybe some menu text too?? I’d love to surprise my daughter for her birthday and adjust this as “???'s Console”. I’ve seen posts that it can be done with Rasberry Pi version on RetroPie, but wondering if Emulation Station on EmuElec from an Android TV box can have some branding changed?? I guess it might involve editing the uncompiled source before compiling, is there any guide on this (if it’s permitted from EmuElec of course).

Thanks for any help & advice,

Cheers, PJC

In the souce code package, look for a directory in which resides several files named with “boot-logo”.

Many thanks. Where is location of Source package you mention?

I looked in EmuELEC/packages at dev · EmuELEC/EmuELEC · GitHub + also looked generally in the source code of the ‘EmuElec 4.2’ download zip of whole package.

Any more help, much appreciated. Thanks again.

Many thanks, please, just two more questions:

1 - Do you know where the intro video is found and can be switched out?
2 - So presumably this: EmuELEC/distributions/EmuELEC at dev · EmuELEC/EmuELEC · GitHub needs to be recompiled into: https://github.com/EmuELEC/EmuELEC/releases/download/v4.2/EmuELEC-Amlogic-ng.aarch64-4.2-Generic.img.gz. Do you know of any instructions for a newbie on how to do this?

Many thanks

PJC

I have never tried it before. Can’t help, sorry.
I think it will be easier to find and replace the intro video and logo files on EmuELEC installation. SSH and find where the files reside.

I found this: Change Bootsplash - LibreELEC.wiki , does this sound like it stacks up for EmuElec too??

Many thanks, PJC

The boot logo cannot be changed (not without recompiling).

You can change the splash by following this WiKi entry.

And Emulationstation supports splash change, just follow any tutorial on the internet to do that, basically just change it from the resources folder or add it to the theme.

Someone already told you how to change the video.

As for your libreelec link, it falls on you to test it

Many thanks EmuElec. I absolutely love your system.

Do you have a guide on recompiling back to the image file (that is used on first boot up) from the source? I’d love to have a go at changing that intro to a birthday message.

Thanks again, PJC

@EmuELEC I tried put a splash.png image in the /splash folder but nothing happens. Is there a cache that needs flushing or anything else I need to do?

Many thanks.

Not sure why you would think that would work, did you not follow the link I posted?

Yes, I followed this: Bezels & Splash screens · EmuELEC/EmuELEC Wiki · GitHub. There isn’t much detail on Splash , it talks mainly about Bezels, but it showed the /storage/roms/splash folder and I found that folder and put a splash.png in there. What did I do wrong please??

I looked at this again and noticed you mentioned upload to /resources folder in your text. I changed the splash_emuelec.svg and uploaded back to /resources folder and overwrote the old one. I also replaced oemsplash.png in /flash, but nothing has changed?

It must be a cache issue?

How do I clear the cache on Emuelec please??

Honestly at this point, just change these files

GAMELOADINGSPLASH="/storage/.config/splash/loading-game.png"
DEFAULTSPLASH="/storage/.config/splash/splash-1080.png"

You will get the splash you want when loading a game and when returning to ES.

Or copy the /usr/bin/show_splash.sh file to /emuelec/bin and edit it to point it to whatever files you have, but like I said, bootlogo cannot be changed unless you recompile.

I know you mean well for your daughter, but the bootlogo is made hard to change for a reason.

Sorry, this didn’t work and strangely .config directory seems to have gone missing now and the loading game and splash that were uploaded to /storage/.config/splash have reverted.

I won’t bother you any more on this. Thanks for trying to help me out. Much appreciated.

I copied the /usr/bin/show_splash.sh to /emuelec/bin/show_splash.sh and changed the path to "/storage/splashvideo.mp4 on that show_splash.sh file and can see from a note in the directory of emuelec/bin that bin files placed in this directory will replace the usr/bin location. However, it doesn’t seem to change anything. is there a cache to clear? My files are placed in /storage/ folder as per the path that is pointed.

Also I can’t copy the files directly to the usr/bin directory as i get an error code 4. Is there a way to change the permissions on this folder (the standard CHMOD doesn’t make any difference).

I found this issue in my googling and have the same issue/questions.
I’m making a box for a friend, and am trying to customize the splash screen.

I’ve uploaded my new intro video and starting splash screens to (overwriting the old files):

/storage/.config/splash/loading-game.png
/storage/.config/splash/splash-1080.png
/storage/.config/splash/emuelec_intro_1080p.mp4

But after reboot, the old splash screens and video are still shown. I see these old screens and video are still located in:

/usr/config/splash/

But that is of course not writeable so I can’t change those files. How can I get EmuElec to point to the /storage/.config/splash/ folder?

it’s explained here, 3 replies up. Changing the Intro Screen and Load screen? - #15 by emuelec

Or copy the /usr/bin/show_splash.sh file to /emuelec/bin and edit it to point it to whatever files you have, but like I said, bootlogo cannot be changed unless you recompile.

The paths are the same though in the original show_splash.sh.

To be clear, this is the splash screen shown when the box/Emulelec boots, not when a game starts.

The splash screen for the game starting did change with the change i made above, the splash screen and starting video when EmuElec boots up did not. Sorry, should have made that clear.