Beelink GT King Pro won't boot usb


I recently buy an usb memory which is 512 gb sandisk ultrafit.
I can’t manage to run emuelec on it. it gets stuck as shown in the picture below.

I also tried with a 32 gb usb, the result is the same. I wrote a ready-made image to usb, same again

don’t see an error, so it just stops right? version of EmuELEC?

installation from usb is not reliable, also not using a large capacity sd. try new installation with smaller capacity sd 32/64 gb if possible

i tried again sometimes it boots and launch front end but when i restart the system loading screen appears
“a start job is running for create volatile files / Kernel time … etc .” sometimes stuck sometimes launchs.

as seen in the video

You can try put the SDHC card in a USB card reader and boot from USB, not from SDHC slot. It works for me. I have several SDHC cards, and some of them have to boot this way.

1 Like

I have no problem booting from sd slot with a sd card. I want to take advantage of the high capacity usb I just bought. 32/64/512 … none of them work well and I believe there is a way to fix this.

ok. now I see that I did not read the post well, although it does not change much. booting from usb doesn’t work well on all boxes and performs worse.

in my opinion it is better option to use an sd only for the system and use usb for external storage (bios/roms/metadata etc)

What you said sounds interesting. can i use usb stick by doing this. I’m very new at this, can you tell me how to do it please? thanks in advance for your answer

its very good info. Ill take my current image of emuelec+storage partitions to 8gb sd card and make an external 512 gb usb setup. I think it will work.

I have another s922x machine (Not beelink)and same problem to you.I have reported a bug to GitHub Emuelec project but seems that no one could solve it.

I think it is for the reason that the USB port do not have correct reading speed.Whille on the first boot it will take long time to write a huge data and finally corrupte the target file.If you meet the same problem as me,check if some files on STORAGE have 0 size.

As my situation,I found a plan, don’t use the usb port but TF card port.It may let a 64g TF card boot up normally.