Segmentation fault when trying to update

Hello. I’m getting segmentation fault when trying to update from 4.4 to 4.5. The same thing happened to me when updating from 4.3 to 4.4, both times on a fresh 4.3 and 4.4 install (just prepared my sd, inserted it, booted, then updated within ES, nothing else).

My device is a GT King PRO, any ideas? Anyone here with the same device? Anything I should try? My SD is 8GB so it shouldn’t be an space issue.

Also, should this topic be on the Amlogic category?

Thanks in advance.

Can you upload a log? If you don’t know how to get it, you can see it here:

PS: If you can’t update from EmulationStation, you can also manually with this method: How to update · EmuELEC/EmuELEC Wiki · GitHub

Thanks, gonna try to get the logs now. As for the manual update, should I get the tar file, or the gz one?


Never mind, it’s the tar one. I can’t get any logs because EmuELEC won’t boot again after the failure, but I was able to get a screencap of the error:

Yes, the exact same thing happened with the manual update. Also tried force updating from 4.5 fresh and all went the same way. The update process always seems to fail at 31%-32% of the “updating system” step.


More info, on a fresh CE 20 install, the manual update (CE 20 to CE 20) works fine, on the same SD card.

After updating the custom ROM I use on my device I got the same segmentation fault error, only this time the process continues. I have no idea how, but I guess somehow this is related to the ROM.

If your running into errors updating it’s probably more reliable to just do a fresh install of the latest EmuELEC.

That’s what I had to do from 4.3 to 4.4 and honestly I have too much configs to waste hours everytime an update comes :frowning:

Your SD Card is only 8GB? Buy a new SD Card Sandisk Extreme’s are good and use 32GB at the very least.

You could also mount the release image and overwrite the storage.img and kernel.img files, but be warned the configs may not always be compatible since your storage config files will be from the previous version of EmuELEC.

You mean kernel and system images from the update tar, for example? No configs should be overwritten then, right?

No, system and kernel images from a downloaded release. Your update images might be corrupt.

They are not, I’ve tried manual, auto… checksums are ok, the process always fails at 31%, is not the update file, it’s something else…

what process? extract the image on ur pc, mount ur sd card then replace the system and kernel image.

That’s what I’m saying, grab the update tar file and get those files, you said “storage.img” but I think you meant SYSTEM image file, they don’t even have extensions. Also, you warned me about config files, but the normal update process do not touch config files so, in the end, it would be a similar update process, only more manual.

sorry yes the KERNEL and SYSTEM images. You have to mount the image, in linux it’s easy, windows you need a program, then you remove your old images on your sd-card, make sure it’s not keeping a shadow copy from recycling, then copy the new ones across.

Yes, that’s what I probably end up doing. Thanks!