Remote Issue - Odroid

Hello. I have an Odroid N2+ and am running emuelec 4.5 on it. I am a noob with all this so I am running into an issue with powering off the system and keeping it off. Whenever I use my roku tv remote to turn the TV off, it turns the Odroid back on. I had another frontend installed before flashing emuelec and it didnt do this, so I am wondering if there is some sort of IR remote setting to prevent this. I have so far been really liking emuelec, but would like to know what changed it to where the roku remote turns it on.

In the EmuELEC first partition that is created, I believe you can alter the Infra-Red Code.

See in Main partitin EmuELEC open config.ini

#------------------------------------------------------------------------------------------------------
#
# IR setup
#   Setup a custom keycode to wake the N2/C4 from suspend or poweroff
#   You can stop kodi and eventlircd and use "ir-keytable -u" to obtain a compatible u-boot
#   IR keycode
#   This setting will require a injected bl301 blob.
#
# remotewakeup='0x31ce4db2'
#
#   decode_type can be one of the following:
#   NEC='0x0', DUOKAN='0x1', TOSHIBA='0x2', RCA='0x3', RC5='0x4', RC6A='0x5', NEC_TOSHIBA_2IN1='0x6',
#   NEC_RCA_2IN1='0x7', RCMM='0x8', NEC_RC5_2IN1='0x9', NEC_RC5_2IN1='0xa', RC6='0xb'
#   This setting will require a injected bl301 blob.
#
# decode_type='0x0' # NEC
#
#   remote power key mask:
#   Some IR protocols implement a toggle bit, this can be ignored by the "and" mask:
#   RC5='0x37ff', RC6='0x1effff', RC6A='0xffff7fff'
#   This setting will require a injected bl301 blob.
#
# remotewakeupmask='0xffffffff'
#
#------------------------------------------------------------------------------------------------------

Thank you very much! I will give this a try.

I realized that it isn’t an IR issue. I unplugged the TV while the Odroid was off and tried to see if the remote for the TV would wake it, I thought it was waking it as I’m turning off the TV with the remote. That does not seem to be the case. When the TV was unplugged the remote had no effect. It seems the Odroid wakes when the TV is turned off but has nothing to do with an IR signal. It would seem this might be a CEC issue, or something like that. I’m no expert on how the TV communicates with the Odroid or what settings in Emuelec allow it. I would like to know if there are settings within Emuelec that may cause this, CEC or otherwise, that I can disable.

I think you might need to modify the dtb file. But this is a very complex task. Do you have the old dtb file for the older EmuELEC you had installed? If so try copying it too your EmuELEC partition backup the current dtb.img file and then rename your old dtb file that was working to dtb.img boot and pray. :smiley:

This is my first time using Emuelec. I was using RetroArena v.3.1.13 previously but ran into too many issues. So far Emuelec is far superior, but I just need to fix this issue with the box turning on when I turn off the TV. Possibly if I can disable CEC or something else that might be communicating with the box through HDMI. This didn’t start to happen until I flashed Emuelec.

Honestly everything else works great. Really happy with it, I just wish I could find a way to fix this so I don’t have to keep unplugging and plugging in the Odroid.

Does the TV have a HDMI setting wake/shutdown device on power? Check in it’s settings.

I could only find CEC settings but it does not list the Odroid to disable the setting. I haven’t found any other settings related to wake/shutdown either. I am beginning to think it is some sort of CEC override since CEC is enabled by default in Emuelec.

You could try re-compiling EmuELEC with the CEC_SUPPORT=no flag.
So for an amlogic-ng device it would be:

PROJECT=Amlogic-ce DEVICE=Amlogic-ng CEC_SUPPORT=no ARCH=aarch64 DISTRO=EmuELEC make image

I’m not positive arguments parsed override the options file for projects, maybe shantigilbert can confirm that.

If that don’t work find your project devices options file and change CEC_SUPPORT=“yes” to CEC_SUPPORT=“no” and rebuild. For example Amlogic-ng options are in EmuELEC/projects/Amlogic-ce/Amlogic-ng/options .
Good luck. :slight_smile: