My GameForce has a problem pressing DPAD after resume

I am using v4.2-TEST-05312021 with GameForce.
After resuming the device from sleep, there is a problem pressing the DPAD button on the emulationstation.
When I press any DPAD button, it seems that an additional left input is generated.
This issue does not occur if I have not put the device to sleep and resume.
Does anyone have the same problem?

I just tried this but I cannot reproduce, do you do anything else before you press power?

Thank you for your reply.
I haven’t done anything else. It happens just by doing the following.

  1. Turn on the power from the power off state.
  2. The emulationstation starts.
  3. Press the power button to sleep.
  4. Press the power button to resume.

The additional left input occurs only when the DPAD button is released, not when held down.

Sorry but I just can’t reproduce on mine, I put it to sleep, turn it back on and the dpad works the same, how are you testing this? and does it affect emulators?

In emulationstation, where I select a system such as NES, GB, etc., change the system with the left and right buttons.
Pressing the up and down buttons does not respond before sleep, but after sleep pressing the up and down buttons causes the system to switch to the left.

I thought that there would be no effect while the emulator was running, but when I checked it with GB (GAMBATTE), it seems that additional left input may occur.

It looks like the following video before and after sleep.
before sleep
after sleep

1 Like

Is that Crystal theme ?. which one is that

The theme I’m using is carbon.
I also tried crystal and a few other themes, but the situation was the same.

Ok. I have not been able to replicate the problem. This was also happening in 4.1?

sorry. I don’t know because I haven’t tried it in 4.1.
However, if it doesn’t happen to other people, unfortunately it may be a problem only for my GameForce.

Can you try with v4.1?

I’m not saying that the problem is unique to your unit, that would be weird.
I use a 4.2 updated from 4.1 and have reset scripts after updating; it would help if you try a new 4.1 image to find out if it is a 4.2 problem (or not

I installed EmuELEC-GameForce.aarch64-4.1-chi.img.gz and tried it right after the first boot without changing any settings, copying any roms, but I got the same problem …

Considering that you seem to be the only one with the issue, I think there is a problem with your unit :frowning:

Okay. After all it is so.
Thank you so much.

I have this problem on V4.2 on a fresh from the box device. It seems as if the DPAD starts to click left once per second if the device is running something.

As an example, scraping titles and then navigating to the game list caused this. Sometimes after exiting a game, it does this. Restarting emuelec stops it temporarily.

I have the same issue: after waking up from sleep, either D-Pad “left” is not working or it is always on.
Rebooting fixes the issue. No problem with the sticks though.

I installed EmuElec 4.2 fresh on my GameForce, no update.

Can anyone with the issue install v4.1 (clean install preferably) and see if this issue was in that version as well? I just cannot reproduce this and I have a few units

I’ll try. I’ll backup everything and reformat the SD card with v4.1.

I can reproduce it with a fresh 4.1 install :frowning:
I made a GitHub issue: [EmuELEC 4.2][GameForce] D-pad issue after waking up from sleep · Issue #667 · EmuELEC/EmuELEC · GitHub