Mario kart cant turn

hello for all, y have some question cant turn right or left in mario kart in emuelec , acelerate ok stop any ok but cant turn some helps please

which system ?

are other games on that same system running normal?

did you (re)setup your controller?

I suppose it refers to Mario Kart 64 … I think this is something about your gamepad, it can happen if the controller does not have analog sticks or is incorrectly configured. Map your gamepad in main menu / controller settings.
If you have analogs and they do not work, try remapping them: entering the quick menu of retroarch / controls / port1 controls /

i have emuelec system version 3.9, the problem is the game in first person in n64 example mario kart ,mario party ,dont turn left or right, how to configured analogs correctly?

I would like to help you but it is difficult without knowing … device / gamepad? Is it an official version 3.9 or a preconfigured one full of games? First configure the controller in emuelec / controller configuration.
If this does not work enter retroarch while playing (hotkey + y) and go to quick menu / controls and check if the option analog to digital = left analog

If it is activated and your analog sticks still do not work, go back to the quick menu / controls / port1 controls and remap your analogs, finally save your new configuration when exiting that menu (save configuration by core)

firend working fine tanks for your help

1 Like

cant help with other question how to make emuelec see psp games in the menu list

Adding psp games with compatible extension (.iso / .cso) in roms / psp folder

ok i do it but emuelec not see the file psp in the menu

Try updating game list in menu / game settings or reboot device

hey some question friend , marvel vs capcom 2 dont execute say this ,bios not found ,can helpme

I can not . This thread must be closed. Open another in general for these questions offering more detailed information accompanied by a log file. On the wiki it explains how.

@juceca21 Solution:

in ssh:
mkdir "~/.config/retroarch/config/remappings/Mupen64Plus GLES2"
nano "~/.config/retroarch/config/remappings/Mupen64Plus GLES2/Mupen64Plus GLES2.rmp"
input_player1_analog_dpad_mode = "0"
input_player2_analog_dpad_mode = "0"
input_player3_analog_dpad_mode = "0"
input_player4_analog_dpad_mode = "0"
save and close.

For Mupen64Plus-Next do the same except the path is:

in ssh:
mkdir "~/.config/retroarch/config/remappings/Mupen64Plus-Next GLES2"
nano "~/.config/retroarch/config/remappings/Mupen64Plus-Next GLES2/Mupen64Plus-Next GLES2.rmp"

The cores should now load up the remap files for the emulators.

I almost forgot also make sure in retroarch.cfg it’s pointing to the following directory:

in ssh:
nano ~/.config/retroarch/retroarch.cfg
find and change too:
input_remapping_directory = "~/.config/retroarch/config/remappings"

Retroarch should notify on game launch a core remap file is loaded. If it doesn’t try the above without " GLES2" on the end.

It should be added soon on the next revision, my PR is: