Pantalla en negro al cambiar resolución

Hola. Me estoy haciendo un mueble arcade y he elegido emuelec como frontend. Lo tengo prácticamente configurado al 100%, pero lo empecé a configurar con el monitor de mi pc.

Ahora he comprado un monitor 5:4 de Samsung y probando resoluciones he ido a poner 480p y al arrancar no se ve nada en pantalla.

Me gustaría saber si hay algúna forma de reiniciar los ajustes de video por consola de comandos o de alguna forma, sin tener que reinstalar todo el sistema.

Y también decir que creía que los monitores de 19" eran 4:3 pero el formato son 5:4 por lo que en los juegos se me queda un trozo de pantalla sin usar. Tengo que probar a estirar la imagen a ver si no se nota mucho, pero en principio la idea era mantener la relación de aspecto original.

si usas linux, o desde windos en carpeta compartida “emuelec” puede editar el archivo “emuelec.conf”(storage / .config / emuelec / configs /) y editarlo. No sé el comando / ruta para hacerlo desde ssh.

1 Like

Gracias. He entrado en esa carpeta y he editado ese archivo, le he cambiado la resolución de arranque y ya funciona.

En ese archivo se puede poner cualquier resolución que queramos? Porque mirandonlas que se peude elegir desde emuelec, no tiene la resolución 1600x1200 que va a ser la que necesite. Al final cambiaré el monitor por uno de 20" con esa resolución que acabo de poner que es 4:3

EmuELEC muestra las resoluciones compatibles con tu dispositivo ,que en el caso de tvboxes son resoluciones HD para tv ;puedes probar con la resolución nativa del monitor pero como digo puede que no esté soportada.

1 Like

Y si cambio la resolución a mano en el archivo de configuración funcionará?

Prueba. Si falla ya sabes cómo cambiarla.

1 Like

Pues he estado probando con el monitor de pc en sus resoluciones compatibles, que no fueran las que vienen por defecto en emuelec, y los juegos a priori funcionan bien, pero los menús para elegir consola, juego, etc se ven mal. He probado con una resolución inferior a 1080p y se veía todo muy aumentado y con una resolución de 1440p se veía todo cuadruplicado. Vamos, que lo que son todos los menús parece que funcionan mal si te sales de sus configuraciones.

No se si habrá solución a esto.

Entiendo entonces que tu dispositivo es compatible con la res.nativa del monitor y es el fronted de EmuELEC el que no se muestra correctamente,supongo que no está pensado para funcionar a resoluciones como esa.

Si hay una solución para ajustar Emulationstation a …1600x1200? Creo es algo que debe responder el desarrollador. El hilo queda abierto por si alguien puede aportar algo nuevo.

Gracias por la ayuda. A ver si alguien conoce una solucion. Estoy por el discord tambien, saludos