Amstrad Emulator Caprice32 has extreme lag after update to 4.4

After updating Emuelec 4.3 to 4.4, the Caprice32-emulator suddenly has massive problems when started. There are audio and video lags from the bootscreen into the game(s).

Even when I load the core [1.10.1 - cap32 (4.5 9aac9cb196 HI)] inside retroarch, the same thing happens: slowdowns, lagging…

Before updating to 4.4, the emulator worked perfect [core version: 1.9.8 - cap32 (4.5 9aac9cb196 HI)]
Any ideas what could be the problem?
Is there something wrong with the cap32-core? And what to do to solve this problem? (Right now I downgraded again to 4.3.)

Is it somehow possible to use the old, working cap32-core with Emuelec 4.4?

Hope, anyone can help me with this issue…

Keep up the great work! Thanks!

This bug is described here: The core does not work, constant noise and extremely slow · Issue #99 · libretro/libretro-cap32 · GitHub
It is already solved in the cap32 repo.
What platform are you on?
Are you on discord?

Bug fixed. You can find replacement cores on discord:
Pull request created.

Yes, that’s the exact problem I’m having!

I’m running Emuelec on Amlogic (EmuELEC-Amlogic-ng.aarch64-4.4).

The discord-link doesn’t work, unfortunately. Can you post a new, working link to the fixed core?
Would be great!

And another question: where exactly do I put the new core into the file-system? Do I have to overwrite the old core-file? Where can I find it? Is this folder correct: /tmp/cores ?

You have to join on discord for the link to work:

You have to overwrite the core in /tmp/cores.

Thank you. Replacing the old core with the updated one worked! Now it’s running smoothly again!