Get complie error on dev branch

I complied the dev brach get some trouble, someone can help me?

env:

lsb_release -a
No LSB modules are available.
Distributor ID:	Ubuntu
Description:	Ubuntu 20.04.3 LTS
Release:	20.04
Codename:	focal

command:

git checkout dev
PROJECT=Amlogic ARCH=aarch64 DISTRO=EmuELEC make image

error:

[001/486] [DONE] build   configtools:host
BUILD      make (host)
    TOOLCHAIN      configure (auto-detect)
Executing (host): /home/levi/EmuELEC/build.EmuELEC-Amlogic.aarch64-4.3/make-4.2.1/configure --host=x86_64-linux-gnu --build=x86_64-linux-gnu --prefix=/home/levi/EmuELEC/build.EmuELEC-Amlogic.aarch64-4.3/toolchain --bindir=/home/levi/EmuELEC/build.EmuELEC-Amlogic.aarch64-4.3/toolchain/bin --sbindir=/home/levi/EmuELEC/build.EmuELEC-Amlogic.aarch64-4.3/toolchain/sbin --sysconfdir=/home/levi/EmuELEC/build.EmuELEC-Amlogic.aarch64-4.3/toolchain/etc --libexecdir=/home/levi/EmuELEC/build.EmuELEC-Amlogic.aarch64-4.3/toolchain/lib --localstatedir=/home/levi/EmuELEC/build.EmuELEC-Amlogic.aarch64-4.3/toolchain/var --disable-static --enable-shared 
configure: WARNING: unrecognized options: --disable-static, --enable-shared
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /usr/bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking whether make supports nested variables... yes
checking for style of include used by make... GNU
checking for x86_64-linux-gnu-gcc... /usr/bin/gcc
checking whether the C compiler works... no
configure: error: in `/home/levi/EmuELEC/build.EmuELEC-Amlogic.aarch64-4.3/make-4.2.1/.x86_64-linux-gnu':
configure: error: C compiler cannot create executables
See `config.log' for more details
FAILURE: scripts/build make:host has failed!
[002/486] [FAIL] build   make:host

The following logs for this failure are available:
  stdout: /home/levi/EmuELEC/build.EmuELEC-Amlogic.aarch64-4.3/.threads/logs/2/stdout
  stderr: /home/levi/EmuELEC/build.EmuELEC-Amlogic.aarch64-4.3/.threads/logs/2/stderr

parallel: This job failed:
package_worker 2 2 486 'build make:host'
Parallel build failure - see log for details. Time of failure: Fri Nov 19 03:39:38 UTC 2021
make: *** [Makefile:12: image] Error 1

more error info in config.log

## ----------- ##
## Core tests. ##
## ----------- ##

configure:2469: checking for a BSD-compatible install
configure:2537: result: /usr/bin/install -c
configure:2548: checking whether build environment is sane
configure:2603: result: yes
configure:2752: checking for a thread-safe mkdir -p
configure:2791: result: /usr/bin/mkdir -p
configure:2798: checking for gawk
configure:2825: result: gawk
configure:2836: checking whether make sets $(MAKE)
configure:2858: result: yes
configure:2887: checking whether make supports nested variables
configure:2904: result: yes
configure:3044: checking for style of include used by make
configure:3072: result: GNU
configure:3103: checking for x86_64-linux-gnu-gcc
configure:3130: result: /usr/bin/gcc
configure:3399: checking for C compiler version
configure:3408: /usr/bin/gcc --version >&5
gcc (Ubuntu 9.3.0-17ubuntu1~20.04) 9.3.0
Copyright (C) 2019 Free Software Foundation, Inc.
This is free software; see the source for copying conditions.  There is NO
warranty; not even for MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.

configure:3419: $? = 0
configure:3408: /usr/bin/gcc -v >&5
Using built-in specs.
COLLECT_GCC=/usr/bin/gcc
COLLECT_LTO_WRAPPER=/usr/lib/gcc/x86_64-linux-gnu/9/lto-wrapper
OFFLOAD_TARGET_NAMES=nvptx-none:hsa
OFFLOAD_TARGET_DEFAULT=1
Target: x86_64-linux-gnu
Configured with: ../src/configure -v --with-pkgversion='Ubuntu 9.3.0-17ubuntu1~20.04' --with-bugurl=file:///usr/share/doc/gcc-9/README.Bugs --enable-languages=c,ada,c++,go,brig,d,fortran,objc,obj-c++,gm2 --prefix=/usr --with-gcc-major-version-only --program-suffix=-9 --program-prefix=x86_64-linux-gnu- --enable-shared --enable-linker-build-id --libexecdir=/usr/lib --without-included-gettext --enable-threads=posix --libdir=/usr/lib --enable-nls --enable-clocale=gnu --enable-libstdcxx-debug --enable-libstdcxx-time=yes --with-default-libstdcxx-abi=new --enable-gnu-unique-object --disable-vtable-verify --enable-plugin --enable-default-pie --with-system-zlib --with-target-system-zlib=auto --enable-objc-gc=auto --enable-multiarch --disable-werror --with-arch-32=i686 --with-abi=m64 --with-multilib-list=m32,m64,mx32 --enable-multilib --with-tune=generic --enable-offload-targets=nvptx-none=/build/gcc-9-HskZEa/gcc-9-9.3.0/debian/tmp-nvptx/usr,hsa --without-cuda-driver --enable-checking=release --build=x86_64-linux-gnu --host=x86_64-linux-gnu --target=x86_64-linux-gnu
Thread model: posix
gcc version 9.3.0 (Ubuntu 9.3.0-17ubuntu1~20.04) 
configure:3419: $? = 0
configure:3408: /usr/bin/gcc -V >&5
gcc: error: unrecognized command line option '-V'
gcc: fatal error: no input files
compilation terminated.
configure:3419: $? = 1
configure:3408: /usr/bin/gcc -qversion >&5
gcc: error: unrecognized command line option '-qversion'; did you mean '--version'?
gcc: fatal error: no input files
compilation terminated.
configure:3419: $? = 1
configure:3439: checking whether the C compiler works
configure:3461: /usr/bin/gcc -march=native -O2 -Wall -pipe -I/home/levi/EmuELEC/build.EmuELEC-Amlogic.aarch64-4.3/toolchain/include -Wno-format-security  -Wl,-rpath,/home/levi/EmuELEC/build.EmuELEC-Amlogic.aarch64-4.3/toolchain/lib -L/home/levi/EmuELEC/build.EmuELEC-Amlogic.aarch64-4.3/toolchain/lib conftest.c  >&5
cc1: error: bad value ('tigerlake') for '-march=' switch
cc1: note: valid arguments to '-march=' switch are: nocona core2 nehalem corei7 westmere sandybridge corei7-avx ivybridge core-avx-i haswell core-avx2 broadwell skylake skylake-avx512 cannonlake icelake-client icelake-server cascadelake bonnell atom silvermont slm goldmont goldmont-plus tremont knl knm x86-64 eden-x2 nano nano-1000 nano-2000 nano-3000 nano-x2 eden-x4 nano-x4 k8 k8-sse3 opteron opteron-sse3 athlon64 athlon64-sse3 athlon-fx amdfam10 barcelona bdver1 bdver2 bdver3 bdver4 znver1 znver2 btver1 btver2 native
cc1: error: bad value ('tigerlake') for '-mtune=' switch
cc1: note: valid arguments to '-mtune=' switch are: nocona core2 nehalem corei7 westmere sandybridge corei7-avx ivybridge core-avx-i haswell core-avx2 broadwell skylake skylake-avx512 cannonlake icelake-client icelake-server cascadelake bonnell atom silvermont slm goldmont goldmont-plus tremont knl knm intel x86-64 eden-x2 nano nano-1000 nano-2000 nano-3000 nano-x2 eden-x4 nano-x4 k8 k8-sse3 opteron opteron-sse3 athlon64 athlon64-sse3 athlon-fx amdfam10 barcelona bdver1 bdver2 bdver3 bdver4 znver1 znver2 btver1 btver2 generic native
configure:3465: $? = 1
configure:3503: result: no
configure: failed program was:
| /* confdefs.h */
| #define PACKAGE_NAME "GNU make"
| #define PACKAGE_TARNAME "make"
| #define PACKAGE_VERSION "4.2.1"
| #define PACKAGE_STRING "GNU make 4.2.1"
| #define PACKAGE_BUGREPORT "bug-make@gnu.org"
| #define PACKAGE_URL "http://www.gnu.org/software/make/"
| #define PACKAGE "make"
| #define VERSION "4.2.1"
| /* end confdefs.h.  */
| 
| int
| main ()
| {
| 
|   ;
|   return 0;
| }
configure:3508: error: in `/home/levi/EmuELEC/build.EmuELEC-Amlogic.aarch64-4.3/make-4.2.1/.x86_64-linux-gnu':
configure:3510: error: C compiler cannot create executables
See `config.log' for more details

Your architecture (tigerlake) is too new and thus unknown to gcc9.
You need to use gcc10 at least. Here is shown how you can switch between different gcc versions:
https://www.cnblogs.com/livelab/p/13049117.html

Thx your reply,I have tried all version gcc from gcc-4 to gcc-10, but not worked.
so finally I use my older I7-4720HQ pc to compile´╝łnew pc cpu I7-1165G7 is tigerLake architecture), the issue solved